hur.cn - 华软网

 热门搜索

升级问题

  作者:未知    来源:网络    更新时间:2017/9/29
我下了7.0的代码为什么老会蹦出以下代码:
it has been migrate to current version format but must also be successfully regenerated
知道是说格式不对,但不知道怎么设置才能用?大家帮个忙!谢谢
------华软网友回答------
不知道你用的是什么版本?
------华软网友回复------
补充一下:我用的是pb8.0
------华软网友回复------
PB8.0升级一下.
------华软网友回复------
能具体点吗,比如操作.
------华软网友回复------
右键target->full build

如果有错误,可以右键->eidt source->修改后再保存->再full build
------华软网友回复------
同意楼上.
由于某些原因,如pb升级、程序编译错误、pb bug等原因可能会出现这种情况。
也可以使用右键菜单中的regenerated一下就可以。
------华软网友回复------
对的,一般出现这样的移植问题都是一下几方面的问题:
PB版本有bug,需要升级到最近版本。
2 要移植的底版本程序自身有严重错误,不能移植到高版本中使用,出现移植了一半显示出错信息的现象,这时就要用右键->edit source->打开该对象的原程序,找到出错的问题,改正后保存->在full build 全编译一下。
3 我总结的经验是,一般都是菜单对象出的问题,影响了联系他的窗体不能移植的问题。比如:默认环境是支持“-”连接符的,但是考虑到软件设计上的标准就在PB环境中取消了使用“-”的选择,这样在该环境中移植有“-”连接符的程序就会出现不能移植的提示错误。      
华软声明:本内容来自网络,如有侵犯您版权请来信指出,本站立即删除。