hur.cn - 华软网

 热门搜索

VS2008制作的安装文件,安装时提示“要求安装.net Framework 3.5版本的组件”的问题

  作者:未知    来源:网络    更新时间:2011/5/25
用vs2008制作了.exe文件,在其它电脑上安装,弹出提示“要求安装.net Framework 3.5版本的组件”,按照提示步骤安装,又不成功。怎样才能在没有安装.net Framwork 3.5的电脑上运行呢?我在网上搜了相关方法,有一种方法如下:      
     需在VS2008中作一下几个设置。
     1、安装部署程序---属性---系统必备---勾选合适的,或者不勾选
     2、项目---属性---应用程序---目标Framework---选择合适的框架
     3、项目---属性---发布---系统必备---勾选合适的,或者不勾选

    
上面所说的第二项和第三项我在vs2008设置菜单里找不到啊。

另外一种方法是这样说的:

将VS08项目改为依赖.netFramework2.0制作安装包。VS08默认.net框架的为3.5,可以在项目属性里修改“目标Framework”这一项,改变项目对.netFramework的依赖版本,设置项目运行在那个框架下。切换到 项目的 启动条件选项卡 -》 netfaramework -> version ->现在你要的 版本

第二种方法的“启动条件选项卡”我也找不到在哪里啊,真是太菜了!望知道的大哥求助!!!
---华软 网友回答---
从解决方案资源管理器上右键属性就可以看见了,是右键你的安装包的工程名
---华软网友回复---
项目——属性——系统必备按钮——选择从与我的应用程序相同的位置下载组建
试试      
华软声明:本内容来自网络,如有侵犯您版权请来信指出,本站立即删除。