hur.cn - 华软网

 热门搜索

VS2008 调试问题!很纠结!!

  作者:未知    来源:网络    更新时间:2010/6/12
点调试,肯定会先出错:
如图:

然后出错:

再点一次调试,然后就成功了,不知为何?

错误信息:
1>------ 已启动生成: 项目: r, 配置: Debug Win32 ------
1>正在编译资源...
1>Microsoft (R) Windows (R) Resource Compiler Version 6.0.5724.0
1>Copyright (C) Microsoft Corporation.  All rights reserved.
1>正在链接...
1>LINK : fatal error LNK1000: Internal error during IncrBuildImage
1>  Version 9.00.21022.08
1>  ExceptionCode            = C0000005
1>  ExceptionFlags           = 00000000
1>  ExceptionAddress         = 0028FCF7 (00210000) "D:\Program Files\Microsoft Visual Studio 9.0\VC\bin\link.exe"
1>  NumberParameters         = 00000002
1>  ExceptionInformation[ 0] = 00000000
1>  ExceptionInformation[ 1] = 00EDD670
1>CONTEXT:
1>  Eax    = 400BC158  Esp    = 003FEF4C
1>  Ebx    = 4000815C  Ebp    = 003FEF74
1>  Ecx    = 00EDD670  Esi    = 400BBFF4
1>  Edx    = 003FEF64  Edi    = 0021D6C0
1>  Eip    = 0028FCF7  EFlags = 00010246
1>  SegCs  = 0000001B  SegDs  = 00000023
1>  SegSs  = 00000023  SegEs  = 00000023
1>  SegFs  = 0000003B  SegGs  = 00000000
1>  Dr0    = 00000000  Dr3    = 00000000
1>  Dr1    = 00000000  Dr6    = 00000000
1>  Dr2    = 00000000  Dr7    = 00000000
1>生成日志保存在“file://d:\VC\r\r\Debug\BuildLog.htm”
1>r - 1 个错误,0 个警告
========== 生成: 成功 0 个,失败 1 个,最新 0 个,跳过 0 个 ==========
好像就是加红那里出问题

而且编译出来的软件win7能用XP不能用!!!
见此贴:http://topic.csdn.net/u/20100612/15/b528f1e3-37c4-4b86-a9cd-c450014331dc.html
---华软 网友回答---
应该是你的VS的C++目录问题,可能你的系统环境变量改变了,建议在Option中的C/C++目录直接选为绝对路径看看
---华软网友回复---
而且我编译的程序也有问题
见下图:
win7下顺利运行:


XP下有问题:

---华软网友回复---
木有人回答?
---华软网友回复---
根据我在公司遇到过的问题,给楼主一些提示,不一定都对
1、首先你是不是用管理员帐户安装的windows7 我建议使用管理员帐户来安装windows7 以及编译程序和调试程序。因为标准用户确实有太多局限。你报错的那个正好是生成link之类的辅助文件的程序。有可能是生成不了。
2、第二个错误 你可以在windows下静态使用MFC类库 编译一个release版本。
我用的windows7 + vs2008 一直没遇到过什么问题。
如果还有问题。可以加装vs2008 SP1补丁。
---华软网友回复---
编译都没通过,你调试做啥
---华软网友回复---
VS2008是有一些怪毛病……
比如代码编译后,进行链接时,linker会莫名其妙的停止工作,必须再链接第二次才成功……
还有,VS2008的调试环境变量和WinDBG是用的同一个,每次调试程序都要加载符号文件,没有的还要下载,时间好长,郁闷……
---华软网友回复---
对,LS我和你一样,就是链接时,linker会莫名其妙的停止工作,必须再链接第二次才成功……有没有什么好的解决办法?
---华软网友回复---
引用 7 楼 czyt1988 的回复:
对,LS我和你一样,就是链接时,linker会莫名其妙的停止工作,必须再链接第二次才成功……有没有什么好的解决办法?
我的也是。

可是奇怪的时我用VS2008写Mobile程序的时候从来没有这个问题。
---华软网友回复---
哦。。原来是这问题。。。你要下个vs2008补丁。。。bug来的..不过再编译就没问题了。。那看你觉不觉得烦了
---华软网友回复---
不知道你是不是这个问题哦。

你应该是在别的电脑上运行不起来吧?在装有VS2008的电脑上能运行?

要是这样的话。在你的类视图->最大的那个类(不知道怎么语言表示了,希望你能找到)点击属性->在里面找到MFC的使用换成“在静态库中使用 MFC"然后编译试下.
---华软网友回复---
win7 用2008有个连接的BUG 一般编译两次就能解决.
---华软网友回复---
2008的固有bug,在项目属性,连接器,常规,增量连接设置为否就可以。
每次设置会很烦,可以装补丁。

因为补丁没装成功,所以我现在都还是在设置。
---华软网友回复---
引用 12 楼 alwayslzz 的回复:
2008的固有bug,在项目属性,连接器,常规,增量连接设置为否就可以。
每次设置会很烦,可以装补丁。

因为补丁没装成功,所以我现在都还是在设置。


电波已收到,了解鸟,谢
---华软网友回复---
装了SP1补丁,顺利解决,谢谢各位大神
---华软网友回复---
引用 7 楼 czyt1988 的回复:
对,LS我和你一样,就是链接时,linker会莫名其妙的停止工作,必须再链接第二次才成功……有没有什么好的解决办法?



win7下用管理员运行vs2008就没问题了!!!
---华软网友回复---
怎么装补丁?
     
华软声明:本内容来自网络,如有侵犯您版权请来信指出,本站立即删除。